Games not downloading

Home Forums Role Playing & Tabletop Games Games not downloading

This topic contains 0 replies, has 1 voice, and was last updated by  JoeClark 5 days, 16 hours ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #896

    JoeClark
    Participant

    Hey guys for the past few weeks i havent been able to download games through origin or uplay and even on my xbox. i cant help but think it has to do with my network. i have forwarded the correct ports for the appropriate programs and my xbox. i have uninstalled and tried reinstalling countless times. The specific games im having trouble with:

    Rainbow 6 Siege on uplay: downloads to 8/35gb

    Battlefield 1 and Titanfall 2 on origin: BF1 downloads to 96% of 8gb

    Titanfall 2 on Xbox: The game installs fine but will only update 1.25/26gb

    I have no idea what else to do. i have tried all suggestions from xbox to fix it, like installing offline and installing the update after install. any help you guys can provide is appreciated.

    For more details : website builder software

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.